Requests for Comments

The internal workings of the Internet are defined by a set of

documents called RFCs (Request for Comments). The general process

for creating an RFC is for someone wanting something formalized to

write a document describing the issue and mailing it to Jon Postel

(postel@isi.edu). He acts as a referee for the proposal. It is then

commented upon by all those wishing to take part in the discussion

(electronically, of course). It may go through multiple revisions.

Should it be generally accepted as a good idea, it will be assigned a

number and filed with the RFCs.

The RFCs can be divided into five groups: required, suggested,

directional, informational and obsolete. Required RFCs (e.g.,

RFC-791, The Internet Protocol) must be implemented on any host

connected to the Internet.

Suggested RFCs are generally implemented by network hosts. Lack of

them does not preclude access to the Internet, but may impact its

usability. RFC-793, Transmission Control Protocol, is a must for

those implementing TCP.

Directional RFCs were discussed and agreed to, but their application

has never come into wide use. This may be due to the lack of wide

need for the specific application (RFC-937, The Post Office Protocol) or

that, although technically superior, ran against other pervasive

approaches (RFC-891, Hello). It is suggested that, should the facility

be required by a particular site, an implementation be done in

accordance with the RFC. This ensures that, should the idea be one

whose time has come, the implementation will be in accordance with

some standard and will be generally usable.

Informational RFCs contain factual information about the Internet and

its operation (RFC-990, Assigned Numbers).

There is also a subset of RFCs called FYIs (For Your Information).

They are written in a language much more informal than that used in

the other, standard RFCs. Topics range from answers to common

questions for new and experienced users to a suggested bibliography.

Finally, as the Internet has grown and technology has changed, some

RFCs become unnecessary. These obsolete RFCs cannot be ignored,

however. Frequently when a change is made to some RFC that causes a

new one to obsolete others, the new RFC only contains explanations and

motivations for the change. Understanding the model on which the

whole facility is based may involve reading the original and

subsequent RFCs on the topic.

RFCs and FYIs are available via FTP from many sources, including:

The nic.ddn.mil archive, as /rfc/rfc-xxxx.txt, where

xxxx is the number of the RFC.

from ftp.uu.net, in the directory /RFC.

They're also available through mail by writing to

service@nic.ddn.mil, with a Subject: line of send RFC-xxxx.TXT, again

with xxxx being the RFC number.

"Knowledge is of two kinds. We know a subject ourselves, or we

know where we can find information upon it."

Samuel Johnson

Letter to Lord Chesterfield

February, 1755

a book of quotes said April 18, 1775 .. the book of Johnson's works

said it's 1755; I'll go with the latter.

-------

Conclusion

This guide is far from complete---the Internet changes on a daily (if

not hourly) basis. However, this booklet should provide enough

information to make the incredible breadth and complexity of the

Internet a mite less imposing. Coupled with some exploration and

experimentation, every user has the potential to be a competent net

citizen, using the facilities that are available to their fullest.

You, the reader, are strongly encouraged to suggest improvements to

any part of this booklet. If something was unclear, left you with

doubts, or wasn't addressed, it should be fixed. If you find any

problems, inaccuracies, spelling errors, etc., please report them to:

Brendan Kehoe

Department of Computer Science

Widener University

Chester, PA 19013

Internet: guide-bugs@cs.widener.edu

UUCP: ...!widener!guide-bugs

If you are interested in future updates to this guide (aside from

normal new editions), discussion about information to be included or

removed, etc., write to guide-request@cs.widener.edu to be placed on

a mailing list for such things.

@dots is actually `. . . .'

"I've seed de first an de last @dots I seed de beginnin,

en now I sees de endin."

William Faulkner

The Sound & The Fury

April 8, 1928

--------

Zen and the Art of the Internet · 第 111 / 120 题